Mamod Jubilee not holding steam

A very popular starting point for Live Steam. With their low cost comes a number of problems which can be discussed here
Post Reply
Rob9090
New User
New User
Posts: 1
Joined: Mon Nov 08, 2021 8:06 pm

Mamod Jubilee not holding steam

Post by Rob9090 » Tue Nov 09, 2021 7:12 am

Good morning. I have a small collection of Mamod engines. But I am new to the SL loco and in the process of building a garden railway. I have a jubilee which is not holding steam long enough for a good run. I have tightened the dome. Whistle which has helped. But I feel I need to be looking at the reverse block but not sure what I need to do. Any help would be much appreciated. Thank you. Rob

User avatar
philipy
Moderator
Moderator
Posts: 3526
Joined: Sun Jan 30, 2011 3:00 pm
Location: South Northants
Contact:

Re: Mamod SL1 / MSS Loco Changing Reverser Block

Post by philipy » Tue Nov 09, 2021 9:44 am

Hi Rob and welcome to the forum.

This thread is 4 years old and on a slightly different topic. You might do better to start a new thread of your own ( Sorry, I can't help with your query, myself).

User avatar
-steves-
Administrator
Administrator
Posts: 1624
Joined: Thu Jul 28, 2011 1:50 pm
Location: Cambridge & Peterborough

Mamod Jubilee not holding steam

Post by -steves- » Wed Nov 10, 2021 10:44 am

I have split the old topic and created a new one for you. :thumbup:
The buck stops here .......

Ditton Meadow Light Railway (DMLR)
Member of Peterborough and District Association
http://peterborough.16mm.org.uk/

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest